Webhook Setup Error: Refresh token has expired

  • 1
  • Question
  • Updated 2 months ago

I referred doc @ https://github.com/ringcentral/glip-botman/tree/bot-provisioner to create my bot, however I keep getting "Webhook Setup Error: Refresh token has expired". Since last 1 week I tried all possible ways/solutions, still no success. Its working on my friends laptop, but not on my laptop. 

Can someone help me ?

Photo of Amit Dandawate

Amit Dandawate

  • 80 Points 75 badge 2x thumb
  • frustrated

Posted 2 months ago

  • 1
Photo of Tyler Long

Tyler Long, Official Rep

  • 4,710 Points 4k badge 2x thumb
Photo of AK

AK, Official Rep

  • 4,362 Points 4k badge 2x thumb

There are two pre-requisites to get the bot running once you set up the ngrok server:

1.) Add the Bot to Glip

Go to the Bot tab of the recently created app in the developer portal. Click on the Add to Glip button.      

This step creates a folder named _cache as pointed by @tyler above. If you want to re-start the process of creating a bot, please delete the folder.

2.) Creating Subscription on the Bot

In the terminal, just run the below command:
$ cd glip-botman
$ php index.php
Note: If you are reinstalling the bot for some reason, please delete the cache and subscription folders and try again.