Webhook for active calls (/presence?detailedTelephonyState=true) with long delay and missing some calls

  • 1
  • Problem
  • Updated 1 week ago
Hi Everyone,

We've been working with webhook since April and everything was working perfectly until this week.

We have an active and valid subscription (checked) for a webhook using:
/presence?detailedTelephonyState=true
/message-store

Suddenly this week it stopped being real-time (delay of 15 to 30 min to show an income call) and it is getting some calls only, not all of them.

Any clue of what could be happening? Is there any known issue related recently?

Any help is appreciated.

Thanks,
Photo of Jeff Secord

Jeff Secord

  • 214 Points 100 badge 2x thumb

Posted 2 weeks ago

  • 1
Photo of Igor Bebin

Igor Bebin, Official Rep

  • 690 Points 500 badge 2x thumb
Hi Jefff,

We're experiencing issues with Subscription/Notification Services, it might cause some delays or missed events, especially for Presence. 

We're working on fix right now and expect it should be resolved very soon today. Thank you for feedback, will keep you updated.

Thanks,
Photo of Jeff Secord

Jeff Secord

  • 214 Points 100 badge 2x thumb
On Friday it was back and working, Today the issue came back again. Do you guys know when it is going to be fully solved? Thanks
Photo of Igor Bebin

Igor Bebin, Official Rep

  • 690 Points 500 badge 2x thumb
Hi Jeff, 

On the previous week, we did some actions to fix the situation. This helped to resolve most of the delays, but some rare misses could be still in place and we're expecting it became fully soon. 

Could you advise what is the delay you're observing? If you can provide delayed notification example with payload it could help as well. 

Thanks, 
Igor