Web hook no longer works for present events while in production.

  • 1
  • Problem
  • Updated 2 years ago
  • (Edited)
We are in production for months. Today at 1.53PM presence hook is no longer being called. 

Then I discover that subscription was not running. The subscription was refreshed less that 24 hours ago much less than subscription expiration. What would be the reason for that?
Photo of Alec Dfour

Alec Dfour

  • 340 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Tyler Long

Tyler Long, Official Rep

  • 8,132 Points 5k badge 2x thumb
Is it restored now? Are there any exceptions in the log?
Photo of Alec Dfour

Alec Dfour

  • 340 Points 250 badge 2x thumb
Actually  subscription was not renewed and expired.  I restarted app, created new subscription. 

When renewing subscription my app gets the list of extensions; to do that the app renews access token and gets this error

refresh token:{  "error" : "invalid_grant",
  "errors" : [ {
    "errorCode" : "OAU-202",
    "message" : "Refresh token was not issued for this application"
  } ],
  "error_description" : "Refresh token was not issued for this application"
}


What is application in this context?
(Edited)
Photo of Tyler Long

Tyler Long, Official Rep

  • 8,132 Points 5k badge 2x thumb
I think application is the app you created in developer.ringcentral.com. It seems that you are unable to refresh your access_token. If access_token expired, subscription will expired too(sooner or later).

I am not sure of the root cause without seeing the source code. Could you please post some sample code?
Photo of Alec Dfour

Alec Dfour

  • 340 Points 250 badge 2x thumb
Yes. You are correct. We updated our app and got new app key. So we need to shutdown app and restart using new app key. A bit of a hassle when you upgrade your app.
Thank you for your help.
(Edited)
Photo of Tyler Long

Tyler Long, Official Rep

  • 8,132 Points 5k badge 2x thumb
You are welcome!