Unauthorized for this grant type

  • 1
  • Question
  • Updated 2 years ago
  • Answered
I have two separate Company Accounts (one main office, one satellite office, each with their own main number) but when calling RingCentral support I hear (press 1 if calling about account called xxxx and 2 if calling about account called yyyy).

Everything worked fine when developing my program in the sandbox for the main office and  the program is fully operational never generating any errors.

When I created a sandbox account for the satellite office, getting the Access Token (exactly as I did for the main office) generates the following and I cant figure out why:

Server: nginx/1.8.0Date: Wed, 20 Apr 2016 00:41:01 GMTContent-Type: application/json;charset=UTF-8Content-Length: 100Connection: keep-aliveRcrequestid: 8e2782ee-0690-11e6-bb68-005056bb8059Routingkey: SJC12P01PAS02X-Loadmetric: 6Www-Authenticate: Basic realm="RingCentral REST API"Content-Language: en


{
"error": "unauthorized_client"
"error_description": "Unauthorized for this grant type"
}

The header is

Authorization: Basic OENPRWxEUHRRMWVYY25PMWl6bk1GUxxxxxxxxxxFfS0d6QW1EaGd6NEVBMlg4TjQybC1TRUtiWXRLamZGSDMydw==
Content-Type: application/x-www-form-urlencoded;charset=UTF-8

The Payload is:
grant_type=password&username=+15621234567&password=mypassword


Any help would be greatly appreciate.
Photo of Orchard Medical Center

Posted 2 years ago

  • 1
Photo of Benjamin Dean

Benjamin Dean

  • 8,602 Points 5k badge 2x thumb
Have you tried removing the plus symbol from the payload?

Have you setup the Sandbox account with a new user in https://service.devtest.ringcentral.com ?

Are you using the correct API Keys (app_key and app_server for your satellite office's new sandbox account)?

Are you using the correct base URI and route: https://platform.devtest.ringcentral.com/restapi/v1.0/oauth/token ?

Have you made sure to add the colon (:) between the app_key and app_secret when you are base64 encoding it?
Photo of CFHE Reception

CFHE Reception

  • 130 Points 100 badge 2x thumb
The problem included the fact that I was doing EXACTLY what you said.

 It seems the correct URI is https://platform.devtest.ringcentral.com/restapi/oauth/token  and NOT https://platform.devtest.ringcentral.com/restapi/v1.0/oauth/token.

When I requested and Access Token with the first URI, I finally saw the message "STATUS: 200"!!!
Photo of Benjamin Dean

Benjamin Dean

  • 8,602 Points 5k badge 2x thumb
So you're all good now?
Yes. All good. Thank you.
Photo of Benjamin Dean

Benjamin Dean

  • 8,602 Points 5k badge 2x thumb
Thanks for the update. :)