Unable to login via softphone

  • 1
  • Article
  • Updated 2 years ago
While trying to test a solution for a customer's answer today, I discovered that I was unable to login via my RingCentral Softphone on Mac using any of my accounts (production or sandbox). I wanted to share an experience that I had today in case other people ran into this issue, what the conditions for the issue are, and how to resolve it:

The scenario: I had my RingCentral soft phone installed, and it was configured to use my Development (Sandbox) account of RingCentral (as documented here: https://developers.ringcentral.com/library/tutorials/test-account.html). Earlier in the day, I installed the most recent update (as recommended) to the software. When I tried to login later, I was unable to do so (no matter what account I tried using, or if I modified/removed the config.ini which allowed me to use my RC-Sandbox account). I kept receiving an error message "Invalid Credentials". I tried using the SSO (Single Sign-On), but that failed too.

The fix: I simply uninstalled the RingCentral for Mac software from my MBP (Move the Application to the trash), and downloaded the latest version from the web (http://downloads.ringcentral.com/sp/RingCentralForMac) and re-installed. Then all was well with the world and I was back to developing.

Hope this helps if you run into the same issue.

Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,662 Points 5k badge 2x thumb

Posted 3 years ago

  • 1
Photo of Yigit Karatas

Yigit Karatas

  • 232 Points 100 badge 2x thumb
I think i am having the exact same issue at the moment. Reinstall didnt help. I cant log in to my sandbox account from windows softphone or ios app
Photo of AK

AK, Official Rep

  • 4,402 Points 4k badge 2x thumb

Did you follow the instructions to setup the Softphone for the Sandbox environment. Kindly take a look at our developer community post here :