SUB-412 when trying to create a webhook

  • 1
  • Problem
  • Updated 4 months ago
I have successfully been able to get my token with the oauth2 process.
From the developer account I have added the following scopes:
ReadContacts ReadMessages ReadPresence Contacts ReadAccounts EditExtensions ReadCallLog ReadCallRecording SubscriptionWebhook

But when I am trying to create a webhook through this request:
POST https://platform.devtest.ringcentral.com/restapi/v1.0/subscription
{
  "eventFilters": [
    "/restapi/v1.0/account/~/extension/~/presence?detailedTelephonyState=true&sipData=true",
    "/restapi/v1.0/account/~/extension/~/message-store",
    "/restapi/v1.0/account/~/extension/~/presence/line",
    "/restapi/v1.0/account/~/extension"
  ],
  "deliveryMode": {
    "transportType": "WebHook",
    "address": "https://requestb.in/wxg5nvwx"
  }
}

I receive this error 403 Forbidden:
{
    "errorCode": "SUB-412",
    "message": "[HUD] extension permission is required for the following event filter: [/restapi/v1.0/account/226393004/extension/226393004/presence/line]",
    "errors": [
        {
            "errorCode": "SUB-412",
            "message": "[HUD] extension permission is required for the following event filter: [/restapi/v1.0/account/226393004/extension/226393004/presence/line]",
            "filter": "/restapi/v1.0/account/226393004/extension/226393004/presence/line",
            "permissionName": "HUD"
        }
    ],
    "filter": "/restapi/v1.0/account/226393004/extension/226393004/presence/line",
    "permissionName": "HUD"
}

Can someone point me on my mistake?

Thanks in advance
Stephanie
Photo of Stephanie

Stephanie

  • 290 Points 250 badge 2x thumb

Posted 4 months ago

  • 1
Photo of Tyler Long

Tyler Long, Official Rep

  • 4,524 Points 4k badge 2x thumb
extension permission is required 

You need to add extension permission to your RingCentral app. Please login your RingCentral developer account to change the permissions.
Photo of Stephanie

Stephanie

  • 290 Points 250 badge 2x thumb
Hi,

Thank you for your answer but I am not sure to know where to add this permission.
I thought I added it by adding EditExtensions.
You are talking about the Settings tab, into the OAuth settings section than in the Permissions Needed, right? I have everything I could add about the Extensions.
I have added all those permissions: ReadContacts ReadMessages ReadPresence Contacts ReadAccounts EditExtensions ReadCallLog ReadCallRecording SubscriptionWebhook EditPresence

What should I add more? The only permissions left are EditMessages, Faxes, Glip, Internal messages, Meeting, Ring out, SMS, VoIP calling.

I don't know what to add more...
Thanks for your help.
Stephanie
Photo of AK

AK, Official Rep

  • 4,342 Points 4k badge 2x thumb
Stephanie,

Thanks for the information. All the app permissions you have look perfect. Well basically, all the permissions you would need is:

Read Messages, Read Presence, Read Accounts, Webhook Subscriptions

We are looking into the issue. Please watch this space for more updates. Thanks.
Photo of Igor Bebin

Igor Bebin, Official Rep

  • 390 Points 250 badge 2x thumb
Hi Stephanie,

There are 2 types of Permissions: User and Application. Above error is specifically for missing User permission "HUD".

I've granted your account with "HUD" permission, could you please check whether it works now?

Just in case, you can chack in via Service Web (under admin view): Users -> Roles -> *Any Role* -> search for 'HUD' permission.

Thanks,
Igor
Photo of Stephanie

Stephanie

  • 290 Points 250 badge 2x thumb
Hi Igor,

Thank you very much for pointing me that, it is working now.
So if I want to create webhooks automatically for my customers I have to ask them to check this option or can I do it for them?

Sincerely,
Stephanie
Photo of Igor Bebin

Igor Bebin, Official Rep

  • 390 Points 250 badge 2x thumb
Stepanie,

"HUD" permission is enabled for the most of Tiers, except some of Developers Tiers. If "HUD" is disabled on account the only way to enable it is to ask Dev Support.

Thanks,