status 403, [OutboundSMS] permission required

  • 1
  • Problem
  • Updated 2 years ago
  • Not a Problem
it works in sandbox for sms:
Receipt(status=200, response={  "uri" : "https://platform.devtest.ringcentral.com/restapi/v1.0/account/665152005/extension/665152005/message-...;,  "id" : 2682755004,  "to" : [ {    "phoneNumber" : "+16304235327",    "location" : "Aurora, IL"  } ],  "from" : {    "phoneNumber" : "+13234308604",    "location" : "Montebello, CA"  },  "type" : "SMS",  "creationTime" : "2017-02-13T15:01:47.000Z",  "readStatus" : "Read",  "priority" : "Normal",  "attachments" : [ {    "id" : 2682755004,    "uri" : "https://platform.devtest.ringcentral.com/restapi/v1.0/account/665152005/extension/665152005/message-...;,    "type" : "Text",    "contentType" : "text/plain"  } ],  "direction" : "Outbound",  "availability" : "Alive",  "subject" : "Test SMS using a RingCentral Developer account - test sms content",  "messageStatus" : "Sent",  "smsSendingAttemptsCount" : 1,  "conversationId" : 6361148894337915435,  "conversation" : {    "id" : "6361148894337915435",    "uri" : "https://platform.devtest.ringcentral.com/restapi/v1.0/conversation/6361148894337915435";  },  "lastModifiedTime" : "2017-02-13T15:01:48.059Z"}, key=null)

however it doesn't work in production:

Receipt(status=403, response={  "errorCode" : "FeatureNotAvailable",  "message" : "[OutboundSMS] permission required",  "errors" : [ {    "errorCode" : "CMN-408",    "message" : "[OutboundSMS] permission required",    "permissionName" : "OutboundSMS"  } ],  "permissionName" : "OutboundSMS"}, key=null)
Photo of Comiere Healthcare

Comiere Healthcare

  • 140 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
I am conducting some experiments right now to see if I am able to recreate this issue and if I do I will report this issue to our engineering team.

In the meantime, developers should keep in mind that unless the effort to match development (sandbox) accounts to closely match that of live (production) accounts, there are specific steps which should be taken to prevent these types of issues:


When a user first authenticates with your application you should get the account phone number list, and ensure the "features" for any company number you plan on sending an SMS with have "SmsSender" in the list:
https://developers.ringcentral.com/api-docs/latest/index.html#!#RefGetAccountInfo


Before attempting to send an SMS message, you should first verify the following:

1. The Extension has a phone number with the SMS feature enabled https://developers.ringcentral.com/api-docs/latest/index.html#!#RefGetExtensionPhoneNumbers

2. Check the User Permissions to be certain the user has SMS enabled: https://developers.ringcentral.com/api-docs/latest/index.html#!#RefGetUserPermissions (I WOULD RECOMMEND THIS FOR EVERY DEVELOPER AT ALL TIMES)
(Edited)
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
I have tested this using my personal sandbox and production account (and the same application), and was unable to recreate the issue you reported.

I would recommend using the links I have provided above to be certain that the account/extension/phone number have SMS enabled as a feature prior to sending the SMS (and if they do not, and your app has a UI component, displaying the appropriate UI to the user for the unhappy path).
Photo of Comiere Healthcare

Comiere Healthcare

  • 140 Points 100 badge 2x thumb
faxes works for production, but sms doesn't work, most likely SMS is disabled for the production phone number

settings is not editable after applied for production. I don't have ReadAccounts permission, I cannot invoke the get APIs to check if SMS enabled?

may I have the admin or any contact who can solve the issue for me?
Photo of Travis Carona

Travis Carona

  • 240 Points 100 badge 2x thumb
Before my SMS was working in production. now I am getting 403 responses, sandbox seems to be ok.
I already have SMS permission enabled.
(Edited)