Softphone texts but won't call out with message about Call/Caller/Callee Status in progress

  • 1
  • Problem
  • Updated 2 years ago
  • Solved
I have a sandbox where I can text out and receive calls but I can't place calls.  This has nothing to do with code as I'm just trying to use the sandbox.  I also have a production account also, but with the config.ini I'm able to login to the sandbox and text and receive call but not place them.  When using the softphone it prompts me for "MyLocation" and "Customer Number" before I can call.  After I call is shows in the sandbox window
Call Status: In Progress
Caller Status: In Progress
Callee Status: In Progress

After 20-30 seconds it goes back to the number pad.  Below are the images.
Photo of Don Klayman

Don Klayman

  • 342 Points 250 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Don Klayman

Don Klayman

  • 342 Points 250 badge 2x thumb
I found if I put in my production phone number in for the custom number it will make the two legged call.  But I need to test my softphone, I'm thinking I need a DID in my sandbox to fully test this.  How do I get that for development as the portal isn't allowing it?
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Have you added a phone to the extension in the Sandbox Online Account Portal (https://service.devtest.ringcentral.com)?

Either that, or use the same number you use to login for "Custom Number".
Photo of Don Klayman

Don Klayman

  • 342 Points 250 badge 2x thumb
I do have the normal default 101 extension for the sandbox.  The issue seems to be that RingOut doesn't want to work with the normal E164 format including the extension.   The softphone settings don't a have a direct dial setup.  I'm thinking to RingOut to the SoftPhone you must have a DID giving a DirectDial option, at least that's what it seems to be.

Photo of Don Klayman

Don Klayman

  • 342 Points 250 badge 2x thumb
I do have the normal default 101 extension for the sandbox.  The issue seems to be that RingOut doesn't want to work with the normal E164 format including the extension.   The softphone settings don't a have a direct dial setup.  I'm thinking to RingOut to the SoftPhone you must have a DID giving a DirectDial option, at least that's what it seems to be.

Photo of Don Klayman

Don Klayman

  • 342 Points 250 badge 2x thumb
I can't resolve this because I can't add a phone number to my user.  When selecting a phone# it always says there are no number available in selected area (see below) no matter what city or area code I use.
Photo of Don Klayman

Don Klayman

  • 342 Points 250 badge 2x thumb
I can't resolve this because I can't add a phone number to my user.  When selecting a phone# it always says there are no number available in selected area (see below) no matter what city or area code I use.  So I chose Los Angelas and it worked.
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
I've just tested this and also was unable to get a RingOut to execute from the SoftPhone on Mac, and additionally have began probing internally to our Engineering team to determine if this feature is disabled in Softphone by default in the Sandbox. In the meantime...

You can use the RingOut API to execute a call which appropriately connected to the SoftPhone (when used as the from.phoneNumber property value) to an external device.
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Okay, I've just learned the solution for this is you must use a Direct Number for the authenticated user to execute outbound calls from the Softphone in Sandbox Mode. Here's how to set that up in a nutshell:

1. Login to the Sandbox Online Account Portal: https://service.devtest.ringcentral.com
2. Select Users from the navigation on the left (blue box which contains count of users in account)
3. Choose the user from the list displayed
4. In the User's context menu which displays to the right, choose "Phones and Numbers"
5. Click on "Add Direct Number"
6. From the phone number selection menu displayed, select the state which correlates to one of the following area codes: 616, 916, 413, 424, 626,323, 518, 607, 904 (FYI: This list may change, if you do not see any numbers available in these area codes, please contact devSupport@ringcentral.com for a list of area codes with active numbers)
7. Choose a number, and continue through the dialogue to purchase your new direct number.
8. When creating an outbound call from the Softphone in Sandbox mode, you must set the "Custom Number" === this new Direct Number

Let me know if this works for you. If you do not wish to purchase a new Direct Number, you will be required to use the API to execute RingOut outbound in the Sandbox.
Photo of Don Klayman

Don Klayman

  • 342 Points 250 badge 2x thumb
Yes, as I pointed out I chose an area code in LA and was able to finish and fully test my app.  The instructions above are good as you must add a phone number to use direct dial otherwise it asks for a custom number which there is no provision in the API for that.  So bottom line is you must have a DID number to test RingOut from the desktop (softphone) app.  Thanks.