softphone desktop app - launch external application is triggering twice - anyone else?

  • 2
  • Problem
  • Updated 2 weeks ago
Anything I enter there (any url, any script) triggers twice when I am called. when using the test button, it only triggers once. But when a call actually comes through, it is triggering twice. Does this happen to anyone else?
Photo of Kaluzynski

Kaluzynski

  • 126 Points 100 badge 2x thumb
  • wish this worked!

Posted 4 months ago

  • 2
Photo of Kaluzynski

Kaluzynski

  • 126 Points 100 badge 2x thumb
For people who are seeing this - I still don't have an official response from RC, but from testing with some of my other coworkers, it seems like this only happens on my extension (I'm the super-admin or whatever it's called). I think this has something to do with it, but I'm not 100% sure. 

To test, I tried logging out of my desktop app, having a non-admin log in, and doing some calls - didn't fire twice when someone else was logged in on my computer & my setup. Then I logged in to my account on another machine with the app downloaded, and it fired twice again. 

I hatched this hypothesis when I was looking in our account and noticed an option to always have the admin's desktop app ring once before moving on to other callers - while we have this feature turned off, its existence suggests that there's some internal routing that allows you to treat the admin's desktop app differently. 

As it happens, we nixed using this feature anyway because we need an action triggered on an answer instead of just the app ringing, so it's kind of a moot point for our instance. On that note, if anyone's built an app using webhooks to trigger an action when the app answers a call, please let me know!