Sandbox unexpectedly gets "The number you dialed is not in service at this time."

  • 1
  • Problem
  • Updated 3 years ago
I have set up a private app that I'm testing in the sandbox. While testing, I suddenly get the following message when I dial the sandbox phone number:

"The number you dialed is not in service at this time. Thank you for calling. Goodbye"

Is there a limit to how many times we can call our sandbox account per day? I am able to send text messages to the number and I get them via the subscription api programatically.

I had just figured out how to subscribe to events and was making great progress on our internal app when this happened.

Thanks!

--Ed
Photo of Polar Operations

Polar Operations

  • 120 Points 100 badge 2x thumb
  • Confused

Posted 3 years ago

  • 1
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Hey Ed,

Have you configured a device for that line? I've not received this message myself before, but thought this might be a good place to start.
Photo of Polar Operations

Polar Operations

  • 120 Points 100 badge 2x thumb
Hey Benjamin,

I am using the number that RingCentral assigned to the developer account. This worked on Friday and this morning but stopped working about an 90 minutes ago. When I say worked, I dialed the number and got the attendant. I was unable to programmatically get any events until about an hour ago but was able to use the API Explorer on Friday and query the "Call Log".

--Ed
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Hey Ed,

Have you logged into the Admin Web Portal for your Sandbox account and made sure to setup a user and configure a device for the user? (here are the instructions for that if you need some help: https://developers.ringcentral.com/library/tutorials/test-account.html)

I've tried to recreate this, but haven't been able to do so. Could you confirm you're able to login to https://service.devtest.ringcentral.com using the Sandbox account's main company number, and once logged in could you make sure you have a user and phone configured then try calling that number from a different line please?
Photo of Polar Operations

Polar Operations

  • 120 Points 100 badge 2x thumb
I am pretty sure everything is set up properly.  This shows the sandbox application:

When I click on the "Web Dashboard" app, here's the Application Credentials:

and the Account Information:
 

You can see the number I am dialing that I'm reporting:

I have dialed this from two phones that are not Ring Central lines, both resulting in the same error.

I did log into the https://service.devtest.ringcentral.com/ site and created a virtual phone number for the primary user (802) 448-8980 since one wasn't there:

That doesn't appear to change anything. (and I get the same not in service message for that number as well)

Thanks again for your assistance.

--Ed
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
I'm guessing that the one user in your Sandbox account is an admin (typically this is extension 101)?

Could you click on the Phones & Devices for that user, and make sure you have added a phone (under 'phones', click on "Add Phone", then enter a physical device number in there which you own). I think that's what's causing the issue (if you haven't added a phone for that user yet). Let me know if that works. :)
Photo of Polar Operations

Polar Operations

  • 120 Points 100 badge 2x thumb
No luck. I've set up an extension with a softphone as outlined in your tutorial.  I can make outgoing calls without a problem but get the same error message when I try an incoming call.

--Ed

BTW: You've got a bad link in that tutorial. In the "Configure Sandbox Account" section you show "Go to https://service.devtest.ringcentral.com" but the underlying link is to platform.devtest.ringcentral.com)
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Hey Ed,

I'm not sure what is causing that issue. You'll want to submit a support ticket to get the core team to help diagnose.

Thanks for sharing the bad href in that link, I've submitted a ticket for fixing.
Photo of Polar Operations

Polar Operations

  • 120 Points 100 badge 2x thumb
Benjamin,

I opened a ticket over a week ago and they still haven't resolved the issue or helped identify why my main number on the sandbox account now gets a "no longer in service" message. Regardless of extension configurations, I would think the main line would still ring when we call it.

We need to validate the APIs can meet our needs soon or we'll be forced to look at other VoIP solutions. We've been a RingCentral customer for almost two years and I'd rather not move but tying our phones into our back office systems is a requirement as we grow.

--Ed
Photo of AK

AK, Official Rep

  • 4,382 Points 4k badge 2x thumb
Hi Ed,

Perhaps there was a setting configuration which was not enabled on the Number and we have got this issue resolved now. 

Kindly continue with the development activities and if you have any concerns feel free to reach out to us at 'devsupport@ringcentral.com'