Sandbox call recordings not saving

  • 1
  • Problem
  • Updated 1 year ago
  • Solved
  • (Edited)
My overall goal is to call someone in the sandbox, then record the call
with *9, and then retrieve the recording thru the REST API. 

The task at hand is to learn how to record phone conversations in the sandbox and play them back.

I have gotten to the point where I set up 2 users successfully in the Sandbox: USER1 and USER2.  I can log into each of their accounts on the web.  I can even leave voice messages with each other too.

However, the call recording does not seem to work.  Here is what happens.  From USER1 softphone, I call USER2.  After USER2 answers and the users exchange greetings, USER1 hits *9 on her softphone keypad and records the conversation that is about 2 minutes long, then hits *9 again then hangs up. 

Expecting to retrieve the recorded call,  USER1 logs into his account and Clicks Messages --> Recordings and nothing is there, even after a half hour of waiting.

Also, when USER1 entered *9,  USER2 did not hear any alert message that the conversation  was being recorded.
What am I missing?  Do I need to activate *9 or something?

Thank you in advance, 
Photo of Joe T

Joe T

  • 182 Points 100 badge 2x thumb
  • striated

Posted 1 year ago

  • 1
Photo of Phong Vu

Phong Vu, Devangelist

  • 5,416 Points 5k badge 2x thumb
Hi Joe,

The OnDemand call recording should be enabled by default. How fast after ending the call did you check for the recording? Can you check again. It takes some time to finish and make the recording available. You can also login and check from the call-log tab for your recordings. If it is still empty, can you test recording calls by pressing the Record/Stop button on the sof-phone instead of pressing *9/*9

Let me know,
Photo of Tyler Long

Tyler Long, Official Rep

  • 9,828 Points 5k badge 2x thumb
Go to  You need to login with your admin account.

And there is a Call Recording section where you can set call recording options. You can check if the settings look good. If not, change the settings and try again.
Photo of Joe T

Joe T

  • 182 Points 100 badge 2x thumb
It worked!  Thanks guys!  Now onward to retrieve the call recording via the REST API.  This is funner than a barrel of monkeys.