Integration: Salesforce for Mac OS X users.

  • 18
  • Idea
  • Updated 3 years ago
  • Implemented
  • (Edited)
We're an all Mac OS X company about to start using Salesforce. Is there integration planned for Salesforce and RingCentral for Mac OS X users?
Photo of Robby Ibrahim

Robby Ibrahim

  • 50 Points

Posted 5 years ago

  • 18
Photo of Marco S. Casalaina

Marco S. Casalaina, Official Rep

  • 354 Points 250 badge 2x thumb
To all here, it would be beneficial to you to install the new RingCentral for Salesforce if you haven't done so already:

https://appexchange.salesforce.com/listingDetail?listingId=a0N3000000B5WKqEAN

This version is much easier to set up, requires no software on the desktop at all and supports Macs too.
Photo of David Montgomery

David Montgomery

  • 50 Points
You don't need to run parallels on the mac to get it to work?
Photo of Robby Ibrahim

Robby Ibrahim

  • 50 Points
Nope. It's all web-based. Working well so far on our Mac farm. 
Photo of Buzzy Castonguay

Buzzy Castonguay

  • 50 Points
Im on a MAC and we cant get this to work??? HELP
Photo of Brandon Filoramo

Brandon Filoramo

  • 50 Points
This is awesome!  Can't wait to use it.  I'm getting this following error however.  How can I fix this?

"Your RingCentral edition does not support Salesforce Integration — please call your RingCentral account representative to upgrade your RingCentral edition."
Photo of Marco S. Casalaina

Marco S. Casalaina, Official Rep

  • 354 Points 250 badge 2x thumb
Brandon,

RingCentral for Salesforce requires RingCentral Premium Edition or above - are you perhaps on RingCentral Office Edition?
Photo of Brandon Filoramo

Brandon Filoramo

  • 50 Points
Yes we are.  And I called to upgrade but our account manager said my account security question was wrong...and NOW we can't figure out where to change that.  Help?
Photo of Marco S. Casalaina

Marco S. Casalaina, Official Rep

  • 354 Points 250 badge 2x thumb
I'm not entirely certain, but my guess is that you need to log into service.ringcentral.com as your company's main extension, then go to Settings->My Settings, then select the very first option on the left hand nav bar (it'll be your name or your company's name). Then click on the User Password box. There you can set your security question. Here's a screenshot:
(Edited)
Photo of Brandon Filoramo

Brandon Filoramo

  • 50 Points
One thing that I've noticed...if I take notes DURING a call, in the SF plugin, once the call hangs up the box seems to "reset" and the notes disappear.  Can this be fixed? 
Photo of Marco S. Casalaina

Marco S. Casalaina, Official Rep

  • 354 Points 250 badge 2x thumb
That may well be a bug, the team is looking into it now. Note too that as of this writing the latest version of the Salesforce integration is 3.7, you can install the latest from the AppExchange page if you have an earlier version:

https://appexchange.salesforce.com/listingDetail?listingId=a0N3000000B5WKqEAN

We've fixed numerous bugs since the original release (which was numbered 3.0 in deference to our old Salesforce integration) so you might try that and see if it fixes the problem.

Nonetheless our team is testing this issue and will issue a fix if we can reproduce it. Thank you for bringing it to our attention.
Photo of Brandon Filoramo

Brandon Filoramo

  • 50 Points
Thanks a bunch for your quick reply here Marco, you've been very responsive and attentive throughout this process!!

Hope I'm not getting too far into the weeds here, but I'm getting the following error when trying to install:

Aura Integration Service Error[{"message":"An internal server error has occurred
Error ID: 606163751-155517 (-1191634670)"}]

Is this a SF thing?
Photo of Marco S. Casalaina

Marco S. Casalaina, Official Rep

  • 354 Points 250 badge 2x thumb
Sorry about that Brandon, yes Salesforce does seem to have some kind of issue right now installing certain AppExchange apps, we have a case open with them about it.

Meanwhile, fortunately there's a workaround. You can install version 3.7 from this alternate link for now:

https://login.salesforce.com/packaging/installPackage.apexp?p0=04to0000000BuxT

Please let me know if I can be of any further assistance.