Salesforce says their extra API service is required to use the RingCentral app with Salesforce Professional. Is it? App docs don't say.

  • 1
  • Question
  • Updated 3 years ago
  • Answered
Salesforce says that their extra API service is required to use the RingCentral integration app with Salesforce Professional. The app documentation does not mention this is required. Is it?
Photo of Lorie Miller

Lorie Miller

  • 50 Points

Posted 3 years ago

  • 1
Photo of Kim

Kim

  • 92 Points 75 badge 2x thumb
For this inquiry, please contact Devsupport@ringcentral.com 
Photo of Lorie Miller

Lorie Miller

  • 50 Points
Will do. Thank you.
Photo of Benjamin Dean

Benjamin Dean

  • 8,602 Points 5k badge 2x thumb
Hi Lorie,

According to our requirements for the Salesforce app (https://developers.ringcentral.com/app-gallery.html#/app/salesforce):

  • RingCentral for Salesforce is available for RingCentral Office® Premium and Enterprise customers.
  • You must have a Salesforce Professional, Enterprise or Unlimited Edition account.
  • Requires Windows® XP or above or Mac OS® X 10.8 Mountain Lion or above.
  • Supported browsers include: ChromeTM 30 (or later), Firefox® 25 (or later), Safari® 6.0.5 (or later), and Internet Explorer® 10 (or later).
According to Salesforce (https://help.salesforce.com/HTViewSolution?id=000005140&language=en_US):
  • Salesforce Editions which have API access enabled by default
  1. Enterprise Edition
  2. Unlimited Edition
  3. Developer Edition
  4. Performance Edition
The reason we say that Professional Edition is the minimum requirement is because you can purchase the extra API services (per the above URL):
*Professional can have API Temporarily turned on by contacting their Account Executive.  Professional can also purchase API by contacting their Account Executive.
Please review the article: Enabling API