RingCentral authentication returns Error Code OAU-153.

  • 1
  • Problem
  • Updated 8 months ago
  • Solved
  • (Edited)
Hello, I am using the sdk 'ringcentral_sdk'
Can anyone help me understand what I am doing wrong here?

I have attached a screenshot of my code, I am only trying to get the authentication.
Note => I have removed sensitive information.



Based off of the docs found here 
https://ringcentral-sdk-ruby.readthedocs.io/en/latest/usage/authorization/Authorization/#using-oauth... 

I have also tried this.


Please note that the documentation is using either older code or wrong use of the RingCentralSdk module. 
::Sdk and ::Platform are uninitialized constants.
Photo of Romina D

Romina D

  • 120 Points 100 badge 2x thumb

Posted 8 months ago

  • 1
Photo of Romina D

Romina D

  • 120 Points 100 badge 2x thumb
There is a comma inside the client configuration.
Photo of John Wang

John Wang, Official Rep

  • 5,476 Points 5k badge 2x thumb
Thanks for following up. I'm glad this has been resolved.
Photo of Embbnux Ji

Embbnux Ji

  • 270 Points 250 badge 2x thumb
Hi @Romina, can you show detail information about error message. For OAU-153, it seems that you pass wrong client id. And could you try this new ruby SDK https://github.com/ringcentral/ringcentral-ruby