oauth/token API not working for my new production account

  • 1
  • Problem
  • Updated 1 year ago
  • (Edited)
I have got my main account production approval just yesterday. I have collected API KEY/SECRET for production and trying to run my ode on it. Very strange that i am getting error and the error part of the response is highlighted below.

"Date: Sat, 25 Feb 2017 09:18:03 GMT  Server: nginx/1.10.2
  WWW-Authenticate: Bearer realm="RingCentral REST API", error="invalid_client", error_description="[ThirdPartyAppAccess] permission required"
  Content-Language: en
  Content-Type: application/json; charset=UTF-8"

I also tried with API Explorer and getting following error

{
"error": "invalid_grant", "error_description": "Invalid resource owner credentials." }
I was also not able to log at https://service.ringcentral.com/login/enter.html?s=1210&localeId=en_US#/number for production account and it gave me the attached screen!!

Please help me asap as i have to graduate my company account to production as well next week.
Photo of Priya Ranjan

Priya Ranjan

  • 90 Points 75 badge 2x thumb
  • Confused!!

Posted 1 year ago

  • 1
Photo of Tyler Long

Tyler Long, Official Rep

  • 5,342 Points 5k badge 2x thumb
Please send email to devsupport@ringcentral.com

It seems like an account permission issue.
Photo of Priya Ranjan

Priya Ranjan

  • 90 Points 75 badge 2x thumb
Many thanks for the reply. I have already submitted the above problem details to devsupport@ringcentral.com from my email account linked with the RingCentral account. Hope to get a reply today i.e. Monday.
Photo of VB

VB, Official Rep

  • 1,290 Points 1k badge 2x thumb
For production password issue, please reset your password by clicking on "Forgot Password?" and follow the wizard. You could also reach RingCentral customer support or your account manager to guide you in resetting your production account password.
(Edited)
Photo of Priya Ranjan

Priya Ranjan

  • 90 Points 75 badge 2x thumb
Thanks for the reply VB.

Seems there is issue with my account which has nothing to do with password. I have already reset the password and i am getting same error error_description="[ThirdPartyAppAccess] permission required" again.

Photo of Benjamin Dean

Benjamin Dean

  • 8,602 Points 5k badge 2x thumb
This error reads as though there is a mismatch of user credentials as compared to the account (either production or sandbox).

Have you updated the API Keys in your application to use your production API Keys as indicated for your app in the Developer Portal?

Have you updated the RingCentral Platform API Base URL you are using in your application code for production: https://platform.ringcentral.com (instead of RingCentral Sandbox API Base URL: https://platform.devtest.ringcentral.com )?

Have you tried logging into the RingCentral Account Portal in Production (https://service.ringcentral.com ) using the user credentials you are attempting to use in your application? HINT: If you cannot login to the Account Portal, you cannot use those credentials for authentication with the API for that environment (either Sandbox or Production respectively).