Cannot establish connection with ring central server

  • 1
  • Problem
  • Updated 1 month ago
Hi,

we promoted application to production, but from time to time (I can say very often) we get connection error:

"A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 199.255.120.210:443"

Could you explain me why?

Thanks!
Photo of zgrada zgrada

zgrada zgrada

  • 230 Points 100 badge 2x thumb

Posted 5 months ago

  • 1
Photo of Phong Vu

Phong Vu, Devangelist

  • 5,406 Points 5k badge 2x thumb
It's hard to say what could be the cause of this problem.

Had this problem happened before when you test it on sandbox? Is the app now running on the same system (browser, OS, internet connection, firewall etc.)

Can you give more details of what type of authentication (password flow or 3-legged authentication), APIs you call from the app etc.

+ Phong
Photo of zgrada zgrada

zgrada zgrada

  • 230 Points 100 badge 2x thumb
Hi,

we didn't have the same problem on sandbox. Application is on the same server.
Actually, it's background windows service, which call ring central server and download fax attachments.
We are using Ring Central C# client.

It's a private, server-only (No UI) application and use password flow| Refresh access token authorization flow.

We use username and pass to authorize.

await rc.Authorize(RingCentralUsername, RingCentralExtension, RingCentralPassword);
Photo of Pankaj Shrestha

Pankaj Shrestha

  • 110 Points 100 badge 2x thumb
I am having the similar issue. Were you able to fix it? could you please share?
Photo of Tyler Long

Tyler Long, Official Rep

  • 9,828 Points 5k badge 2x thumb
It seems like network issue. Do you have stacktrace? Or which API call throws this exception?
Photo of zgrada zgrada

zgrada zgrada

  • 230 Points 100 badge 2x thumb

System.Net.Sockets.SocketException

A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 199.255.120.210:443

Flurl.Http.FlurlHttpException: Call failed. An error occurred while sending the request. POST https://platform.ringcentral.com/restapi/oauth/token 

---> System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: Unable to connect to the remote server 

   at System.Net.Sockets.Socket.EndConnect(IAsyncResult asyncResult)

   at System.Net.ServicePoint.ConnectSocketInternal(Boolean connectFailure, Socket s4, Socket s6, Socket& socket, IPAddress& address, ConnectSocketState state, IAsyncResult asyncResult, Exception& exception)

   --- End of inner exception stack trace ---

Photo of Tyler Long

Tyler Long, Official Rep

  • 9,828 Points 5k badge 2x thumb
Are you trying to do password flow? Could you please try this app: https://github.com/tylerlong/RingCentralPasswordFlow/blob/master/RingCentralPasswordFlow/Program.cs ?  Let's see if you can reproduce the issue.
Photo of zgrada zgrada

zgrada zgrada

  • 230 Points 100 badge 2x thumb
We already use password flow:

await rc.Authorize(Username,Extension, Password);
Photo of Tyler Long

Tyler Long, Official Rep

  • 9,788 Points 5k badge 2x thumb
Did you try the project I mentioned? It is known to work. Let's see if it is your local network issue.
(Edited)
Photo of Pankaj Shrestha

Pankaj Shrestha

  • 110 Points 100 badge 2x thumb
I am having the similar issue. Were you able to fix it? could you please share?
Photo of Tyler Long

Tyler Long, Official Rep

  • 9,788 Points 5k badge 2x thumb
This thread is about network issue so it really depends on your network connection. 

If you are unable to fix this issue and you think your network is fine, please send an email to devsupport@ringentral.com
Photo of Pankaj Shrestha

Pankaj Shrestha

  • 110 Points 100 badge 2x thumb
We are using Azure , and moreover we have two different apps (one has call log perms and other has sms perms used by two separate application). The call log api is working smoothly but the sms one is having issue.
Photo of Tyler Long

Tyler Long, Official Rep

  • 9,788 Points 5k badge 2x thumb
That sound strange. As I said, could you please send an email to devsupport@ringentral.com and include details about the issue? Do remember to include your clientId, clientSecret, error message and/or sample code.