Api requests not showing in sandbox api calls

  • 1
  • Problem
  • Updated 6 months ago
  • Solved
  • (Edited)
My api requests are not showing in the sanbox api calls website.

The api requests are successfull and does return a correct response. but when I look into the dev site under sandbox there is no api calls recorded even error requests.

I am using this api endpoints

- account info
- message-store
- call-logs
- sms
- oauth/token

This prevents me from requiring the graduation requirements. Please Help.
Photo of Aaron Jistel

Aaron Jistel

  • 80 Points 75 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Hello Aaron,

Thank you for reporting this issue. We have identified this as an issue and are currently working towards resolution.

I will update this post when the solution is released.
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Hello Aaron,

We have deployed a fix, and new API requests will display in the Developer Portal - Analytics for your application at the top of the hour for the previous 60 minutes of API request data.

We are working on a solution to retroactively reconcile the data which is missing from the 24th-30th, but you are able to use the system moving forward.

Please let me know if you see this operating as expected for you.
Photo of Spring IT

Spring IT

  • 310 Points 250 badge 2x thumb
I am experiencing this same issue, and have been testing throughout the day today, as well as yesterday and Friday. At some point today, two (2) calls were logged to the sandbox analytics. I have made somewhere between 50 and 100, if not more, individual requests today alone. In short, your fix does not seem to be affecting my app, and if so, it is very, very behind.

Thanks.
Photo of Memorable Inc

Memorable Inc

  • 60 Points
I am experiencing the same issue, taking into account the data is updated on an hourly basis.
Photo of Aaron Jistel

Aaron Jistel

  • 80 Points 75 badge 2x thumb
Its showing now. Thank you so much.
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Outstanding. Thank you for reporting the good news as well as the bad Aaron, it helps a lot.
Photo of Limosys Software

Limosys Software

  • 80 Points 75 badge 2x thumb
Hi All, I am having the same issue right now. There were several successful and some failed calls to the sandbox, but it shows no activity. Please help.
App Name: JLimoGUI
Photo of VB

VB, Official Rep

  • 1,470 Points 1k badge 2x thumb
Hi ,

I could see the analytics for your account for the API calls on Sandbox for your account. Please choose Sandbox on top right corner to see analytics for Sandbox account when you login and choose analytics for your application. 

Photo of Limosys Software

Limosys Software

  • 80 Points 75 badge 2x thumb
Hey VB, you said you were able to see our activity in sandbox. I still cant see it and I am looking forward to apply for production. Please help
Photo of Limosys Software

Limosys Software

  • 80 Points 75 badge 2x thumb
Hi VB,

I am looking at Sandbox, its not an option to see Production at present since my app haven't graduated yet. Please see image

Photo of VB

VB, Official Rep

  • 1,470 Points 1k badge 2x thumb
Here it is .... 
(Edited)
Photo of Dipesh Patel

Dipesh Patel

  • 90 Points 75 badge 2x thumb
Hi,

We are making the api call to get the recording content but that does not show up in Analytics.

And also we are facing the issue that, API doc says we require "ReadCallRecording" permission to get call recording, so we have added to our permission list, and it is allowing to download the recording also, but issue is that it is creating problem in submitting app to production, it say error in app permission, and if we remove it app permission issue gets fixed, but we then get error while downloading recording.
Photo of AK

AK, Official Rep

  • 4,382 Points 4k badge 2x thumb
Could you provide the name of your application on Developer Portal?
Photo of logita

logita

  • 60 Points
I am also getting the same issue.I have made all api calls required for production account but on status and review page its showing Your app hasn't made any API calls in Sandbox yet.