Active Call API Call (PHP) returns Internal Server Error

  • 1
  • Problem
  • Updated 2 years ago
  • Acknowledged
Until today we have been using active calls via the API via cron job.  However this has stopped working and are receiving:

Unable to login to Ring Central Internal Server Error. Consult RC Support.

When calling that particular API Call.

We can Authenticate fine (receiving Access Tokens etc) and we can call 'call-log' successfully.  

We have tried this using the Ring Centrral API Explorer and it seems it is only the active-call api that is failing with this 500 Error.

Any help would be much appreciated.
Photo of Ashley Nicolson

Ashley Nicolson

  • 110 Points 100 badge 2x thumb

Posted 2 years ago

  • 1
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,622 Points 5k badge 2x thumb
Are you using the PHP SDK?

If not, could you provide the full request/response with headers (stripping out your API keys and tokens) please?
Photo of Ashley Nicolson

Ashley Nicolson

  • 110 Points 100 badge 2x thumb
Hey there - this also doesn't work via your API Explorer 

https://developer.ringcentral.com/api-explorer/latest/index.html

So I don't think its a PHP SDK issue.  I am perhaps thinking it is account restricted (overusage?) as it had been working previously for the past weeks of development.
Photo of Ashley Nicolson

Ashley Nicolson

  • 110 Points 100 badge 2x thumb
Hi there - would I need to connect support for this as it is still not working via the API Explorer page using my App details (though other calls do i.e. Auth and call-log).

Many Thanks
(Edited)
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,622 Points 5k badge 2x thumb
Are you both receiving the following error.message: "Internal Server Error. Consult RC Support." and the response body object contains a property named "eventId" which appears to be a UUID?
Photo of Ashley Nicolson

Ashley Nicolson

  • 110 Points 100 badge 2x thumb
Using the API Explorer I receive the following for 'active-call'
{
  "message": "Internal Server Error. Consult RC Support.",
  "eventId": "eb734ca8-e6dc-4213-87d6-f584b19d52bf"
}

- Thanks
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,622 Points 5k badge 2x thumb
Yes, thanks Ashley.

I've reached out to our engineering team who has started investigation. Myself and one of our Developer Relations Engineers tested this in both Sandbox and Production, and this doesn't appear to be an issue in Production, only in the Sandbox environment.

Could you please submit a developer support case with the details from our thread to make sure your issue and the resolution is tracked properly: https://developers.ringcentral.com/api/support-cases/create
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,622 Points 5k badge 2x thumb
This should be fixed now, our engineering team deployed a hotfix last evening to resolve this issue.

Could you confirm if things are working for you again in the Sandbox please?
Photo of Ashley Nicolson

Ashley Nicolson

  • 110 Points 100 badge 2x thumb
Hi there, unfortunately I now receive a 404 response on both the server and the API Explorer Page

This was the result back from using the API Explorer page:

Request URL
https://platform.devtest.ringcentral.com/restapi/v1.0/account/~/extension/~/active-calls

Response Body
no content

Response Code
404

Response Headers
{
"date": "Fri, 29 Apr 2016 17:18:32 GMT",
"routingkey": "SJC11P01PAS02",
"content-language": "en",
"content-length": "0",
"content-type": null
}
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,622 Points 5k badge 2x thumb
Yes, thank you for your patience Ashley.

As of 9:07am Pacific time on April 29, 2016, the RingCentral Sandbox API's, non-oauth related resources and endpoints are currently returning HTTP 404 error responses. This issue is being actively investigated by our engineering team for a resolution.

This issue only appears to be impacting our Sandbox API's non-oauth resources. Developers are still able to make requests to /oauth/* endpoints in the Sandbox, but all other API resources are currently returning HTTP 404 errors.


Production API endpoints are not experiencing this issue. We will update this message once the issue has been resolved. If you experience any issues outside of this, or if you experience this issue in Production, please create a Developer Support case immediately with as many details as possible.
Photo of VB

VB, Official Rep

  • 1,410 Points 1k badge 2x thumb
This issue has been completely resolved on Sandbox environment.