[OutboundSMS] permission required

  • 1
  • Problem
  • Updated 2 years ago
I worked in sandbox  16503514555, and could send SMS . today it stopped and got error says 403 [OutboundSMS] permission required, I did not change anycode. is any way I can get permission back to send sms like before in sand box? it worked very well before.

https://platform.devtest.ringcentral.com/restapi/v1.0/account/~/extension/~/sms";
Photo of Point of Rental Software

Posted 2 years ago

  • 1
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Which application is this please?
CallerLog_Private
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
I was unable to recreate this issue and have some diagnosing/debugging tests/questions you can run to isolate this issue further:

1. Does your extension's serviceFeatures include an object with the featureName === "SMS" && is enabled === true, respectively?

GET /restapi/v1.0/account/~/extension/~/ HTTP/1.1
Host: platform.devtest.ringcentral.com
Authorization: Bearer {{REPLACE_WITH_YOUR_ACCESS_TOKEN}}
Accept: application/json
Content-Type: application/json

The result will be details about the extension you are currently authenticated as via the API. The response will contain a "serviceFeatures" property which is an array of serviceFeatureObjects).

2. Is from.phoneNumber of your SMS POST body an SMS enabled phone number from which your authenticated user can send an SMS?

GET /restapi/v1.0/account/~/extension/~/phone-number HTTP/1.1
Host: platform.devtest.ringcentral.com
Authorization: Bearer {{REPLACE_WITH_YOUR_ACCESS_TOKEN}}
Accept: application/json
Content-Type: application/json

The result will be a list of phone numbers which your currently authenticated user is permitted able to set as "from.phoneNumber" while creating outbound communications. The response will contain a list of phoneNumberObjects and each object will have a "features" property which is an array of features enabled for that phoneNumberObject. Match your SMS from.phoneNumber to the phoneNumberObject records.phoneNumber and validate that "SmsSender" is a feature which is enabled for the phoneNumber you are using as the "from" of your SMS POST body please.

Please report the results of these tests here so I can help you appropriately.
Thank you for reply.
1. SMS  enabled is False. maybe that's why , but where can I change it to True? 

"featureName" : "SMS",    "enabled" : false,
    "reason" : "AccountLimitation"

2.https://platform.devtest.ringcentral.com/restapi/v1.0/account/~/phone-number
 I get phone Number is : +16503514555
(Edited)
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
In this case, the reason is provided that it is an account-level limitation, this means you would need to contact support/sales to enable.

Since you stated this was working, but then it stopped as of yesterday...I have contacted our Engineering and Platform team about this change of state you have reported. Once I hear back from them, I will have more information.
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
I looked at the settings for your Sandbox account and it is a HIPAA Compliant account.

When a RingCentral account is a HIPAA Compliant account, SMS for the entire account is disabled for all users, phone numbers, and extensions.

Unless an administrator requested that HIPAA compliance be enabled for this Sandbox account, I am unsure how you were able to send an SMS initially (unless you were using a different account perhaps).
Photo of Yanmei

Yanmei

  • 396 Points 250 badge 2x thumb
Our Administrator sent request to  Chris.Murphy on 11/18, but still did not get answer back yet. do you know who we should contact? thank you.
Photo of Benjamin Dean

Benjamin Dean, Alum

  • 8,642 Points 5k badge 2x thumb
Chris would be the right person to start that conversation. I pinged him and asked if he could reply in-kind.