"Invalid resource owner credentials" PHP

  • 1
  • Problem
  • Updated 11 months ago
  • Solved
I'm just trying to do this:
require('../vendor/autoload.php');
$sdk = new RingCentral\SDK\SDK('******', '*******', RingCentral\SDK\SDK::SERVER_SANDBOX);
$sdk->platform()->login('16079303113', '', '********');

But am getting this error:

Fatal error: Uncaught Exception: Response has unsuccessful status in /var/www/html/vendor/ringcentral/ringcentral-php/src/Http/Client.php:43 Stack trace: #0 /var/www/html/vendor/ringcentral/ringcentral-php/src/Platform/Platform.php(276): RingCentral\SDK\Http\Client->send(Object(GuzzleHttp\Psr7\Request)) #1 /var/www/html/vendor/ringcentral/ringcentral-php/src/Platform/Platform.php(363): RingCentral\SDK\Platform\Platform->sendRequest(Object(GuzzleHttp\Psr7\Request), Array) #2 /var/www/html/vendor/ringcentral/ringcentral-php/src/Platform/Platform.php(183): RingCentral\SDK\Platform\Platform->requestToken('/restapi/oauth/...', Array) #3 /var/www/html/ajax/fax_prescriptions.php(7): RingCentral\SDK\Platform\Platform->login(Array, '', '******') #4 {main} Next RingCentral\SDK\Http\ApiException: Invalid resource owner credentials in /var/www/html/vendor/ringcentral/ringcentral-php/src/Http/Client.php:54 Stack trace: #0 /var/www/html/vendor/ringcentral/ringcentral-php/src/Platform/Platform.php(276): RingCentral\SDK\Http\Client->s in /var/www/html/vendor/ringcentral/ringcentral-php/src/Http/Client.php on line 54


I have double and triple checked the password.
Photo of George Shih

George Shih

  • 90 Points 75 badge 2x thumb

Posted 1 year ago

  • 1
Photo of AK

AK, Official Rep

  • 4,372 Points 4k badge 2x thumb
George,

Have you been able to Login successfully into Sandbox Service web with the same credentials:
https://service.devtest.ringcentral.com

It looks like your sandbox account has not been activated by the email which you would receive initially. Could you confirm the same for me, please?
(Edited)
Photo of George Shih

George Shih

  • 90 Points 75 badge 2x thumb
Ah. Thank you! Didn't notice the activation email.
Photo of George Shih

George Shih

  • 90 Points 75 badge 2x thumb
Is there a way to resend activation?
Photo of AK

AK, Official Rep

  • 4,372 Points 4k badge 2x thumb
I have resent the activation email to the one tied to the developer account. 
Photo of Raffaello Galli

Raffaello Galli

  • 60 Points
I need the activation email to be resent for my account. Is it possible? Thanks in advance.
Photo of AK

AK, Official Rep

  • 4,372 Points 4k badge 2x thumb
You can resend the activation email by logging into Developer Portal and click on the Top Right Profile Image -> Sandbox Accounts 

If you do not find an option, kindly provide the name of your Organization or the Main OCmpany Number on Developer Portal and I could re-send the activation email for your sandbox account. 
Photo of Lonnie Ezell

Lonnie Ezell

  • 70 Points
I'm having a similar problem. There's no link to re-send Activation email. When I click the Activation link in the email I received, it says I've already been activated, but if I try to login at https://service.devtest.ringcentral.com it says I need to be activated, so I seem to be caught in a loop.

My organization name is TestMe DNA. How do I get this resolved so that I can get back to building? 
Photo of AK

AK, Official Rep

  • 4,372 Points 4k badge 2x thumb
Hi Lonnie,

Your Sandbox account should be activated now. Can you login again please?
Photo of Lonnie Ezell

Lonnie Ezell

  • 70 Points
That did it. Thanks so much! Fixed on the first try. Much better experience than what I've been having with USPS support. Keep up the great work!
Photo of Lee

Lee

  • 520 Points 500 badge 2x thumb
FYI.

I was having the same problem and looked on our Barracuda email security and the email sent was blocked due to bad PTR.
Photo of AK

AK, Official Rep

  • 4,372 Points 4k badge 2x thumb
Lee,

Could you provide the Org name on the Developer Portal and we can take a look to see if the Sandbox Account has been activated already 

Can you provide the Baracuda Logs via support ticket? You can open a support case using one of our support channels:
https://developer.ringcentral.com/support.html

or you can send us an email to devsupport@ringcentral.com with the necessary logs.
(Edited)
Photo of Lee

Lee

  • 520 Points 500 badge 2x thumb
It wasn't activated as I didn't receive the email. ;) 

After I pushed the email to me I activated fine and all is well.

Was just posting so you guys know there might be an issue with your SPF (sorry not PTR) for the server sending those emails.

Looking on my Barracuda Cloud Email Security there are other emails not being received due to "Bulk Email".. I've white listed so not a problem for me now but it's probably that "getsatisfaction.com" domain causing the problem.
(Edited)
Photo of Lee

Lee

  • 520 Points 500 badge 2x thumb
Received-SPF: fail (mx1410.ess.rzc.cudaops.com: domain of account-activation@ringcentral.com does not designate 192.209.29.142 as permitted sender)

is the error on that one email i saw.